إصلاح: .NET Framework 4.7 غير مدعوم في نظام التشغيل هذا

.Net Framework هي بنية أساسية للبرمجة مقدمة من Microsoft. ستحتاج إلى .Net Framework لتشغيل تطبيقات وخدمات مختلفة. تأتي معظم التطبيقات التي تتطلب NET Framework. محملة بملفات التثبيت الخاصة بها أيضًا. لذلك ، سيتم تثبيته تلقائيًا على نظامك عند تثبيت أحد التطبيقات. ولكن ، قد ترى خطأ ".NET Framework 4.7 غير مدعوم على نظام التشغيل هذا" عند تثبيت أحد التطبيقات. سيمنعك هذا الخطأ من تثبيت التطبيق بنجاح. قد ترى هذا الخطأ عند محاولة تثبيت .Net Framework كتطبيق / خدمة قائمة بذاتها.

سبب حدوث هذا الخطأ هو نفسه المذكور في رسالة الخطأ. على الرغم من أن .Net Framework مدعوم على نظام التشغيل Windows 10 ، إلا أنه غير متوافق مع جميع إصدارات Windows 10. لذا ، إذا كنت ترى هذه الرسالة ، فإن السبب الأكثر احتمالاً لهذا الخطأ هو أنك تقوم بتشغيل إصدار Windows 10 الذي غير متوافق مع .Net Framework.

الطريقة الأولى: تحديث Windows 10

الحل الوحيد لهذه المشكلة هو ببساطة تحديث Windows 10. يُنصح بالتحقق من تحديثات Windows حتى لو كنت تستخدم أحدث إصدار من Windows 10. نظرًا لأن المشكلة ناتجة عن نظام تشغيل غير متوافق ، قم بتثبيت كل Windows 10 المتاح من المرجح أن تحل التحديثات المشكلة. يمكنك أيضًا التحقق من الإصدار الدقيق لنظام التشغيل Windows 10 والإصدار المطلوب بواسطة .NET Framework باتباع الخطوات الموضحة أدناه.

  1. اضغط مع الاستمرار على مفتاح Windows واضغط على R.
  2. اكتب winver واضغط على Enter

  1. يجب ذكر نسختك في النافذة المفتوحة حديثًا. الرقم بعد الإصدار (في السطر الثاني) هو رقم الإصدار الخاص بك. يجب أن يكون الرقم 1507 أو 1709. أول رقمين يمثلان السنة ويمثل الرقم الثاني الشهر. لذلك إذا كان لديك إصدار 1709 ، فهذا يعني أنك تقوم بتشغيل إصدار تم إصداره في سبتمبر 2017

  1. أنت الآن بحاجة إلى التأكد من أن لديك إصدار Windows 10 المتوافق مع .Net Framework. انقر هنا وانقر فوق متطلبات النظام

إذا نظرتم الى نظام التشغيل المعتمدة القسم، تقول ويندوز 10 الذكرى تحديث و يندوز 10 صانعي التحديث . نظرًا لأن الكثير من الأشخاص ليسوا على دراية بأرقام الإصدارات المرتبطة بتحديثات Anniversary و Creators ، فقد ذكرناها أدناه

  • تحديث نوفمبر (1511)
  • تحديث الذكرى السنوية (14393)
  • تحديث المبدعين (1703)
  • تحديث Fall Creators (1709)
  • تحديث Spring Creators (1803)

كما ترى ، فإن تحديث الذكرى السنوية يحتوي على رقم الإصدار 14393 وتحديث المبدعين لديه الإصدار 1703. لذلك ، إذا كان لديك إصدار أقل من 14393 ، فلن تتمكن من تثبيت .NET Framework 4.7 على نظام التشغيل Windows 10. الآن ببساطة قم بتحديث Windows وتأكد من أن لديك أحدث إصدار من Windows 10 وحاول مرة أخرى.